1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

pimpin out a U14T mity mitz hightop.

Discussion in 'Mitsubishi Minicab' started by werase643, Mar 19, 2020.

  1. werase643

    werase643 Member

    Today I tried to decode the wiring and figure how all the speed limit shit worked.... then reality kicked in... i don't care. knew there was interlock between the black box.... the speedo..... and the fuel pump relay.... first up.... WTF, why is there a ckt board for the fuel pump relay..... well need power to fuel pump..... wired in a 30a relay.... got fuel pump working. speedo.... don't care today. ignition...... get rid of the black box and built a heat sink for the GM HEI ignition..... 4 wires!!!!!!!! wired in the 4G82 dist. installed a test plug.... dayam.... SPARKY!!!!!!!!!!!!!!!!....
    the carb is not happy has leaky float and some issues i do not like. i'm ordering a 40 mm harley D carb off of FLEBAY. fires on snort!!!!! happy day!!!!!!!!!!

    pulled out the dash again the new master cyl might be here sat and it helped when looking for the fuel pump relay . there is post from years ago about cutting the black wire with yellow tracer.... yeah that wire is all over the place.
     
    Last edited: Apr 17, 2020
  2. werase643

    werase643 Member

    got the 40 mm ebay CV carb last night... and the 40-44mm intake boot..... yeah it was bigger than the carb. ordered one size smaller. was jonesing so bad... took the way to small intake boot and put it in a pot of boiling water for 20 minutes..... got it soft enough to install carb. then let it cool down. tonight i plumbed it in... got a choke cable temp installed and it RUNS!!!!!!!!!!!!!!!!!!!!!!!! used a t fitting for the fuel supply.... so the fuel returns anything not needed before it gets to the float.. started hooking up the coolant linesand need to get a shorter v belt.... i think the alt unlocked itself... probably will die soon but hopefully last long enough to test drive.... also still need to re do the 5th gear shift rod fix.... didn't cut enough off
     
  3. mr.mindless

    mr.mindless Member

    Ready to be a speed demon! nice
     
  4. werase643

    werase643 Member

    runs.... idles with some choke. gunna have to play with the jets. built a intake flange out of an exhaust flange. installed a 3/8x 31.5 v belt.... alt spins but will probably die soon. rad hoses all tied up and antifreeze in... no leaky. installed the prop vlv and rebiolt brake lines. fought for hrs to get the air out of the brake lines.... still have to work on that..... took it for a ride up the driveway.... yeah walk of shame back.... fuel pump decided to not... pump fuel.... hooked up a pony tank and got it back to the front yard.... fuel pump pumped into tank.... WTF.... still kinda need to work on fueling issue. and brakes........ but it moved under its own power... no speed limiter from what i can tel..... also no 5th or reverse.....
     
  5. mr.mindless

    mr.mindless Member

    Might be time for a fresh oil filter! looks extra rusty next to that shiny bright carb.

    Is that Aisin unit a brake pressure switch or proportioning valve?
     

    Attached Files:

  6. Jigs-n-fixtures

    Jigs-n-fixtures Active Member

    Just looking at it, I would say it is either a proportioning valve, but since I’m only seeing one inlet and one outlet, I am tending towards a delay valve, particularly if you have front disc and rear drum.

    The delay valve, delays the pressure rise to the rear drums for just an instant to keep them from locking up too easily, when you don’t have a load in the bed.

    I had a 77 Toyota Pickup, that would lock the rear brakes if anyone besides me drove it. It was my daily driver, and as the delay valve progressively failed, I had learned to compensate for it. After a couple of people drove the truck and complained, I had my room mate, who was a line mechanic at the Toyota dealer drive it. He knew immediately what was wrong, and bought the replacement part the next day when he was at work
     
  7. werase643

    werase643 Member

    swapped out the link arms from frame to LCA. with the cushman ones. Should prevent rubbing the tires on the links... they are bent differently than U14T
    drilled out a bunch of 5 MM broke bolts and installed the front mud flaps from Cushman and reinstalled the washer/rad overflow tank.
     
  8. werase643

    werase643 Member

    reread the ebay post and was wondering where the extra 4-6 jet are..... post said.... inside.... guess i'll take it apart
     
  9. werase643

    werase643 Member

    no luck on the jets.... re assembled the interior and cleaned out parts van to determine what i need or want to keep and separate out what i can get rid of.
     
  10. werase643

    werase643 Member

    the 40 mm ebay carb that comes with extra jets.... didn't. went to busted knuckle shop and all he had was a 50 pilot jet. it's runnin all by itself now. then pulled the trans out 2 times today to figure out why no 5th or rev... then adjusted the shift levers.... then disconnected the levers and manually shifted everything.... then tweaked the shifter rod that i had to fab.... it was a tiny bit off. all better now. cut off the cushman muffler and temp fit the 3G81 muffler to it and just need a coupler....(tomorrow) then ran it for 30 to 45 minutes.... t-hen- decided to test drive it up the driveway(1/2 mile) got to the road and said wtf.... took it 1/2 mile up the road and back.... yup died right in front of the driveway... pushed it into the driveway.... yup no fuel going to the carb.... drug it back to the house.... good thing i bought 3 fuel pumps.... tomorrow swap out the #1 fuel pump.
     
  11. werase643

    werase643 Member

    yes this is the rants and fleeting thoughts in my brain. today #2 cheep ass chinese fuel pump. installed. tried them lighter solder shrink tube connectors for the wires.... they are pretty kewl... test drove it about a mile.... probably rich on the idle.... bit lean on the main. thinking i will get a low pressure fuel regulator and stop feeding extra fuel back to the tank. brakes are working probably need to bleed the lines.... again and get the front rotors cleaned up a bit. best part... didn't have to do the walk of shame from the street to the house!!!!!!
     
    Limestone likes this.
  12. Limestone

    Limestone Active Member

    Your making great progress. I'm enjoying this!
     
  13. werase643

    werase643 Member

    today is compare the 25mph speedo cluster to the 140kph cushman cluster..... i'm gunna guess the elec connection of the speedo on both is a feed to the speed limiter ckt. so i'm gunna guess that it is not important..... now how to creatively cut the face of the cushman speedo to fit into the U14T so the speedo will read up to 140.... instead of 25..... and not look like a 3 year old did the modification.....i wish me luck.....
     
  14. werase643

    werase643 Member

    well there were a couple glitches but i think it turned out kinda ok the speedo face plate sticks out a 1/4 inch or so....but it looks fair.... will try to install tomorrow pics might show up. the issue was the cushman speedo drive is thicker than the olderU14T unit so since i couldn't make room in the back of the cluster it had to push out a lil in the front... but the cover did go back on.... so kinda good.....
     
    Last edited: May 20, 2020
  15. mr.mindless

    mr.mindless Member

    Sorry for the delay. Packed up everything and moved house over the past week, been quite crazy!

    Glad you got the shifters figured out, here's the speedo pics
     

    Attached Files:

  16. werase643

    werase643 Member

    installed a set of NGK plugs.... the old champions..... 1.3.4. white.... 2 black..... since it's now running time to finish the tune-up stuff.... delay.... what like 13 hrs.... i appreciate it. hope all is well....
     
  17. mr.mindless

    mr.mindless Member

    I didn't even remember how long I'd let it sit

    Will take a long time to fully settle in but it's SO worth it. Big lot in the country with a huge shop ❤️️
     
  18. werase643

    werase643 Member

    you SUCK..... loan me the shop..... put it in my front yard
     
    Limestone likes this.
  19. mr.mindless

    mr.mindless Member

    I did my time working in the dirt, and then 11 years in (and in front of) a 300sqft garage...
     
  20. Limestone

    Limestone Active Member

    Seems like we all have to earn our stripes! Other wise we just wouldn't appreciate it as much!!!o_O
    Limestone
     

Share This Page