1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

96 Sambar KS4 and I can't get the 4x4 to engage

Discussion in 'Subaru Sambar' started by James Mullis, Apr 26, 2021.

  1. James Mullis

    James Mullis New Member

    96 Sambar KS4 and I can't get the 4x4 to engage. No light on dashes well. I have verified i have power to the 4x4 solenoid when button is depressed. Vacuum lines appear to be good to actuator. Vehicle has been parked for several years so I'm thinking stuck solenoid or stuck shift forks? Any ideas on troubleshooting would be great! Thanks
     
  2. Jigs-n-fixtures

    Jigs-n-fixtures Well-Known Member

    Get a hand vacuum pump, and a vacuum gauge. You can use the vacuum pump to apply vacuum and see if it works. If it does activate with direct vacuum, you use the vacuum gauge to determine where it gets lost.

    On my Hijet the 4wd light is tied to a switch, which confirms that the actuator has moved.
     
    Limestone likes this.
  3. Ohkei Dohkei

    Ohkei Dohkei Active Member

    Just connect the vacuum line going to the solenoid to the one going from the solenoid and bypass it. If it goes into 4wd, it's your solenoid.
     
    Limestone likes this.
  4. James Mullis

    James Mullis New Member

    Fixed! I unplugged actuator harness with vacuum lines still hooked and was getting 12v on middle terminal but no voltage or ground on the outside terminals. If I supplied ground to either outside terminals one would put engage 4wd and the other would take it out. Turned out my 4wd relay was not switching like it should. Replaced and good to go!
     
  5. Jigs-n-fixtures

    Jigs-n-fixtures Well-Known Member

    James, please go in and edit your message title to show you have solved the issue. It will help the next person.
     
  6. Rick Melloh

    Rick Melloh Member

    When my original TT2 solenoid failed, it worked intermittently at first, then not at all, leaving me stuck in 4wd. I tried giving the solenoid assembly a light whacking with the handle of a screwdriver. It would work again briefly, to return me to 2wd. I replaced the solenoid with a new one and everything is perfect.

    I also disassembled the old solenoid, which turned out to be compromised by rust and failed seals. I cleaned the adjoining faces of the assembly, reassembled it and put it in the parts box as an emergency backup. I think it might work again in a pinch. I tested it by blowing and sucking on the separate ports. The valves were working again, the solenoid plunger/actuator is once again moving freely.

    The original solenoid worked for 19 years. I think I am safe for now. If I put the old one back in service, I know corrosion will quickly return to now uncoated surfaces, rendering it unreliable again, but I have a better understanding of how the thing works.

    Changing out the solenoid is a simple 15 minute task, most of the time spent getting out the tools, removing the engine cover, keeping track of what vacuum hose goes where, wrestling with the forever connected electric coupling covered in grease and dirt and putting everything back where I found it when done. I recall the solenoid cost me about $150.
     
  7. Jigs-n-fixtures

    Jigs-n-fixtures Well-Known Member

    You can probably substitute the solenoids from a Toyota pickup in to replace the stock ones. It is just a valve moved by electricity.
     
  8. fmartin_gila

    fmartin_gila Active Member

    Mid 70s Toyota FJ series had a underdash manual vacuum switch for control which might possible be used. Don't remember much about it as of now but I had to patch one up sometime in the early 80s that my son owned. You would have to do some research to see if it might work for you.

    Fred
     
  9. rkrenicki

    rkrenicki Active Member

    The proper solenoid is part number 33145KA180. It used to be available at US dealers, but it has since been discontinued. It looks like SuperMiniTrucks and Yokohama carry it, although they charge twice what Subaru does.
     

Share This Page