1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

96 joypop EFI turbo stalling on startup

Discussion in 'Microvans' started by Chad Cataldo, Apr 14, 2022.

  1. Chad Cataldo

    Chad Cataldo New Member

    anyone run into this? been searching for a few days to no luck cold start in the morning it cranks up fast and fires right up but stalls a few seconds after being started. cycle the key and fire it back up and its fine.

    also idle dropping to almost the point of stalling with any electrical load
     
  2. t_g_farrell

    t_g_farrell Active Member

    Not sure about turbos but on the carbed I experience the following:

    1. Have to pump the gas on cold start and maybe crank 2 times to get it running.
    2. On cold start it needs to run for a minute or so before its smooth at idle
    3. When gets really warmed up, the idle appears to be too low and if any electrical load is applied it doesn't idle up (includes radiator fan, heater fan, lights etc)

    Things I will do to solve these issues:
    1. When I replace all the coolant hoses I will make sure the choke housing is cleaned up inside and out.
    2. I need to warm it up good and hot and then retune the carb mixture some and set the idle.
    3. Make sure the mechanism for idling up on electric load is working and adjusted right. I had to do this for the AC immediately because it would cause the engine to stall out. For the AC it was really just the vacuum pot had to be adjusted so when it kicked up it actually increased the idle. I suspect at one time a new carb was put on it in Japan and these mechanism were never setup right.
     

Share This Page