1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Sel's 1992 Suzuki Every Van Progress

Discussion in 'Microvans' started by SirSelrahc, Nov 17, 2021.

  1. SirSelrahc

    SirSelrahc Member

    Hello all!

    This thread is to keep track of the progress of my 1992 Suzuki Every Turbo Van.
    EDIT: This thread will be mainly maintenance updates and work done to the van.... with the occasional fluff lol.


    My Every is a 1992 Turbo. Rear wheel drive, Right hand drive, and 5 speed manual. I believe I am at about 78k on the odo. I love the Aero kit! Kinda makes it look like a mini euro sprinter.




    My van is honestly in very good condition. Paint is all original and nearly flawless. No rust. No real dents. The livery on the sides is worn out. I will probably remove it and have the paint corrected. I am thinking about doing a full wrap at some point. We need more Itasha lol. For now... a few peek on the back.




    Interior carpet, seats, and curtains are perfect. I have floor mats in front and back, along with Suzuki mud mats in the front seats. I also have both hand bar and divider bar for the back seats. Cargo area similarly in great condition as well as the head liner.

    The only thing done to the van so far is front plate and stickers on the back. It doesn't really need much.

    I plan on following in the footsteps of t_g and doing the hoses and some misc. updates. Want to replace the plugs and wires. My brakes feel ok but I may change those out as well. I also thought about a larger turbo later.

    I have seen people put larger turbos on the Cappuccino and I believe this is the same engine. Will research.

    I need to have the wheels removed and cleaned up. They look like absolute garbage right now. They are in great shape but the clear is shot. I think I want larger wheels but I want to keep the low profile of the van.

    This is my daily driver. I have taken it to a few car meets. If you are in the Jacksonville, FL area hit me up.
     
    Last edited: Dec 15, 2021
  2. t_g_farrell

    t_g_farrell Member

    Wow yours is fancy inside and in very good condition. I don't have a divider bar, instead I have a strap that goes on the front bar and fastens on the seat side somewhere. I don't have it installed, the dog likes to sit in the rear passenger seat.
     
  3. t_g_farrell

    t_g_farrell Member

  4. SirSelrahc

    SirSelrahc Member

    Put my van up on ramps to change the oil and take a look at the underside. Realized you don't even need to it on a ramp to change the filter or drain the oil lol. Nice fresh 10w30 synth and a new filter.
    While it was up in the air I did discover my rear wheel boots are a bit stiff and one of them is split. It is throwing grease.... yummy! I am glad these little vans have that guard to keep the grease "contained"


    Got new parts on order and on the way including new boots all around. Anyone have a source for seat covers for these little vans?
     
  5. SirSelrahc

    SirSelrahc Member

    Well... ran into my first major issue. I broke down this evening. Overheat.
    I was on the highway just about to get off my exit when I noticed it. Didn't hear anything but the temp shot up super fast. Pulled over and turned her off. She was steaming as I stopped.


    I could smell the rad fluid. Took a peek under the back and sure enough... it was everywhere. Once it cooled down I fired it back up for a quick moment to make sure it sounded fine for a moment. Seems ok. Oil is still good and clean as well. I am hoping I didn't do too much damage. Got a tow home.

    I will need to take a peek in the next few days. I suspect the thermostat was stuck and it overheat and blew off a hose? Or maybe a hose just came off. The odd thing is the rad was cold and full. But I clearly threw out fluid...... and when i turned to start she was hot. Thoughts?

    To be safe I have a new thermostat on order. I also have a new water pump on the way just to have a spare. Also, when removing the front bonnet One of the clips just... disintegrated. I also ordered all new clips and a few spares. Started to get new

    I am HOPING it is just a hose that came loose. I should probably order new ones as well. I was hoping to attend Jan C&O show but looks like I will hafta postpone. Cant risk an overheat away from home again at the moment.

    Will update here when I know more.
     
    Last edited: Dec 29, 2021
  6. t_g_farrell

    t_g_farrell Member

    Sorry to hear that. Hope its not serious.
     
  7. SirSelrahc

    SirSelrahc Member

    Ok so I found the problem....


    The hose that connects to the oil filter got a split in it. Between a dead battery and me being very dumb this took me much longer to find than it should have.
    The original hose was super soft. Once I found it I replaced it with nice sturdy line to get me back up and running.

    Thank goodness this did not cause any more problems!

    Once I got the hose replaced.... I had to burp the line. I have never done this before and did not burp it good enough the first time. I was driving local to test and it started overheating again. Back home I ordered a spill free funnel kit... which did not quite fit. After a temp fixm putting the van on ramps, and burping the system properly... we are all good to go!

    No more overheating! On top of that I learned how to properly bleed the van now which is a win.
     
    t_g_farrell likes this.
  8. SirSelrahc

    SirSelrahc Member

    I have been watching others with the same van and all of the paint issues that are out there. I learned these vans seem to be single stage paint.

    Since my paint is in very good condition I have decided to have my van paint corrected and have a ceramic coat put on it to protect the paint. I want this thing to look good for a long time. But that leads me to one eyesore of a problem.... the livery.
    From a distance on one side it looks great. On the other side... the one I don't show... not so much.


    The livery is original but it is cracking and tearing off bad and fast. The more I wash the van the worse it is getting..... Every wash chunks are pulling off. Sometimes small, sometimes large. And its sometimes leaving the glue behind and it looks ugly.


    This looks like crap.

    Since I am having the paint corrected I decided to have the livery removed as well. I have dropped the van off at a local shop to do all the work for me. They will be removing all factory livery and decals and correcting the paint on the entire van. Also de-badging it for this process.

    I have taken detailed measurements and closeup photos of the livery and logos. I plan to have them remade in the future. I also ordered new Suzuki emblems for the future.

    Lastly, while it is being worked on I am having the wheels cleaned up and powder coat. I let my brother pick the color..... fingers crossed. My intent is to get new wheels soon so they can be hot pink for all I care. Ill be sure to post pics when I have them!

    Could I pull the livery myself? Probably. But time is money and this is a very busy week for me. Leaving this to the pros.
     
  9. t_g_farrell

    t_g_farrell Member

    Mine is a 2 stage, color topped by a clear coat. You sure yours is single stage?

    Is that livery peeling off the paint or just exposing the base of the vinyl graphics? I see what you mean now. I never saw that in the pics.

    So that line to the oil filter was for coolant? I guess cause you are turbo. I don't think I have a line there at all.
     
  10. SirSelrahc

    SirSelrahc Member

    The bumbers are 2 stage. But the rest does appear to be single to me. The person correcting the paint agrees as well. Im not sure.
    Yeah the livery on one side was killing me. It started out small but was failing bad. In come places it was all coming off.... adhesive and all. The gray areas are where the adhesive is staying on the paint. After every wash it was getting worse and worse.
    As for the line, yes. There is a coolant line that runs through where the oil filter is. Not sure what caused the split but I did replace it. I need to replace all my lines... they are very soft rubber.

    I have a few pics of the van being worked on now... it is looking soooo good.
     
  11. SirSelrahc

    SirSelrahc Member

    Little sneak peek of the van progress.....


    The livery came off with heat, plastic blades, and some cleaner.


    Super pleased at the condition of the paint overall. Couldn't be happier with its original condition... and now I'm even more ecstatic. It's in such great shape!
    Once the paint correction is complete and polished up we will be applying a ceramic coating to the car to protect it. Later this year I will look at applying new livery or vinyl to the sides.

    Rear bumper does have some clearcoat failure ill need to address at some point. For now we are sealing it up.

    The wheels are being powder coat. My brother picked the color and he choose a dark metal maroon. I'm still unsure about the color.... here is to hoping! If it doesn't turn out good ill re-do them once I know what vinyl I end up with. I may plastidip them another color if I don't like in the mean time. The rims were in bad shape and needed to be cleaned up either way. And honestly... ill be getting new ones later.
     
    t_g_farrell likes this.
  12. t_g_farrell

    t_g_farrell Member

    Yeah my roof had massive clearcoat peel going on, thats why I plastidipped it white. Looking good but miss the graphics.
     
  13. kip thompson

    kip thompson Member

    Where did you find the body clips
     
  14. kip thompson

    kip thompson Member

    Where did you get your body clips
     
  15. SirSelrahc

    SirSelrahc Member

    MegaZip.net
    Just enter your VIN and see if they have ya covered. I was able to order every clip I needed and a few of each to have as spares. :)
     
  16. SirSelrahc

    SirSelrahc Member

    Im not going to lie.... I do miss the graphics. I took measurements and detailed photos. I may recreate them. Or maybe ill even incorporate the logo and graphics into a vinyl wrap for the sides.
     
  17. kip thompson

    kip thompson Member

    I put my vin into the mega zip site, it returned no results. Can you ship me 5 of those I will gladly pay you
     
  18. SirSelrahc

    SirSelrahc Member

    You need the exact ones in the pic? They should be similar between the years. I just checked a few years ahead and it was the same clip.
    Here is their list of all their Carry and Every variations. Watch the serial numbers to get close. Some have serial number ranges for slight changes in production. From what I see its not many changes most mid-production runs.
    Suzuki CARRY/EVERY Car & Auto OEM Parts | 1873 (megazip.net)

    Here is the parts list for the ones that fit my van (91-92.) Alot of these are likely interchangeable.
    1991 - 1992 Suzuki CARRY/EVERY DE51V OEM Parts | Japan sales region, , 65334 (megazip.net)

    Here is a link to the exact parts for the front clip and little tab clips on the front grill.
    front grill / grill guard for 1991 - 1992 Suzuki CARRY/EVERY DE51V | Japan sales region, , 476706-65334 (megazip.net)

    If you buy from there don't forget to use the code at the top of the site. They are almost always running a 10%+ off but you must enter the code.
    Most major pieces are out of stock. Like doors etc. But the breakable items like clips and consumables are usually there.

    Let me know if this helps or if you need any more assistance. I could order them for ya but why pay double shipping :)

    I ordered new tail lights and headlights from there just a bit ago.
     
  19. kip thompson

    kip thompson Member

    Thanks very much
     
  20. SirSelrahc

    SirSelrahc Member

    And here is the end result.... fully de-badged and de-vinyl. Paint fully corrected. It turned out amazing. A blank canvas for graphics now!

    I am so pleased with how everything turned out! I think I want to change the fog lights to JDM yellow now. And change the lights in general. I do have new emblems but not sure if I will put them on yet or not.

    Uploading images here may end up being a pain. Looks like space is limited. What is everyone doing as a solution? I do have Instagram (link in sig) but I use albums and I don't think you can link to individual images in an album?
     

Share This Page