1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

No power in 5th gear???

Discussion in 'Daihatsu Hi jet' started by Brandon Phillips, Jun 9, 2021.

  1. Hey fellas,

    Symptom#1: As the title says my 94 hijet has no power or pull when switching from 4th to 5th gear. It will actually slow down. I use to hit 110kph no problems now it struggles to do 80kph.

    Symptom #2: Taking off from a light or stop is slow slow slow if the AC is on. Gotta turn that sucker off for any acceleration.

    All of this is making me lean towards a vaccum advance problem, after some previous starting issues I have the carb dialed in to a nice 1200 idle and solved that whole issue.

    Any other thoughts? Whats the surefire way to test if the advance is working or is the culprit?
     
  2. Jigs-n-fixtures

    Jigs-n-fixtures Well-Known Member

    Get a hand vacuum pump. Take off the cap and remove the shield, so you can see what is happening inside, and apply vacuum to the chambers, and see if the plate moves. then try to rotate the plate and see if the advance weights and springs are moving.
     
    Limestone likes this.
  3. bobjonah

    bobjonah Member

    Before you take it apart, check if there are one or two vacuum lines to the distributor. If so, one is for advance and the other is retard. Switch them and then see how it works. You may have them reversed, and that will cause what you describe.
     
    Limestone likes this.

Share This Page