1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Need HELP

Discussion in 'Daihatsu Hi jet' started by jody, Aug 5, 2018.

  1. jody

    jody Member

    Pulled out carb and intake to do a rebuild and lost all my photos. Trying to put things back but having a real hard time. Not sure where all these hoses go and there's lots. I have an S83P with EF-CS engine in a 1993 jumbo. Anybody got some photos of the layout they could post. I would really appreciate any help I can get.
    Thanks in advance.

    Jody
     
  2. ttc

    ttc Active Member

    Partsfan parts fiche has pictures of the carb and vaxuum lines
     
  3. jody

    jody Member

    Thanks ttc. Went to the site and registered. They have parts but could not find any pictures of vacuum lines. Did I miss something??
    I'm still at a loss of where these lines go.
    Jody
     
  4. ttc

    ttc Active Member

    I take a look for links and I also may have pdf for your truck on my laptop
     
  5. jody

    jody Member

    That would be great if you have them. Please let me know.
    Thanks again.
    Jody
     
  6. ttc

    ttc Active Member

  7. jody

    jody Member

    Hi again.
    Thanks so much for the link. There are a lot of similarities but I don't think it's the right one. I'm not sure where you got that from on the site as I couldn't get anything close to that. My truck is a v-S83P - JTDW
    With the EF-CS engine.
    S83P - 128788 chassis
    Got anything like that? Even a few photos would get me started.
    Thanks again.
    Jody
     
  8. bobjonah

    bobjonah Member

    I know what you mean. I rebuilt my S83P Jumbo Engine ( EF-CS ) last year, and without photos, I would never have figured it out. If you can send me your e-mail address, I will send you the photos.
    Choke timing on the carb is critical. Mine is close, but still not correct. It starts and runs great, but still a bit rich all the time. The vacuum tree is also important. Mine was broken, so a new one was needed, and I also replaced all of the vacuum hoses - you will need @ 20 feet .
    While I was at it, I also put a hose on the distributor cap vent and routed it into the intake , and a hose and filter on the distributor body, routed to a nice dry place up under the seat, so It now circulates nice dry, clean air thru the cap - no more condensation.

    Cheers
    Bob Jonah
     
  9. jody

    jody Member

  10. jody

    jody Member

    Hi guys.
    I'm still at a loss here trying to put together this puzzle. Any help would be greatly appreciated.
    Jody
     
  11. ttc

    ttc Active Member

    I may have some manuals I will have to look. As I deleted some of the stuff I had
     
  12. jody

    jody Member

    I had purchased a manual but it didn't cover the CS engine and really wasn't worth anything close to what I paid for it.
    I have no idea where to find anything that could help me out except this form.
    Always appreciate the help.
    Thanks
    Jody
     
  13. bobjonah

    bobjonah Member

    Did you receive the photos that I sent? I sent two lots.
     
  14. jody

    jody Member

    Hi Bob.
    No. I have not received them yet.

    Jody
     
  15. jody

    jody Member

    Hi Bob
    Checked my email and even my junk email and there is nothing there. Can you please try again. Looking forward to getting my unit running again soon.
    Thanks
    Jody
     
  16. jody

    jody Member

    Just wanted to say a big thank you to Bob for the photos. Truck is running finally and those pictures and diagrams from Bob made it possible.
    Great forum and great help.
    Thanks again
     
  17. Steve S83

    Steve S83 New Member

    Bob, I'm a 93 S83P EF-CS owner as well and just started tackling the timing belt and water pump. Carb runs good but auto choke spring is broken and I plan to have to rebuild the carb at some point. Could you send your pictures my way as well?

    My email is sjpaschal@gmail.com

    Also, have any of you had any experience with the timing belt/water pump on the EF-CS? I see the timing marks and I believe I know where the corresponding marks on the case are but I would appreciate some confirmation. Also, does anyone know for sure if its an interference engine? I assume it is but have heard so many things on the forums I'm not sure. Plan to do a compression test after new belt to be sure but any advice would be much appreciated.

    Thank you!
    Steve
     

Share This Page