1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

need help wont run think its a carb issue

Discussion in 'Suzuki Carry' started by garrett, Oct 27, 2015.

  1. garrett

    garrett New Member

    i already posted thish in the mazda thread but since from my understanding these trucks are almost the same i will post here as well

    ok so my truck (mazda badges but has suzuki id plate) was running pretty good then my water pump started acting up so i replaced it. ever since this happened the truck will start up when cold and have a high idle. i can rev it up and it runs fine on the high end. when i try to let it idle it will kill and then i cant get it started again without letting it sit for a while. to me i think it is something in the carb like the float is stuck. has anyone every experienced this? if so what are some options of getting it to run properly?
    all input greatly appreciated thanks: sidenote this thread is awesome for trouble shooting and i have fixed many things from using these forums!!
     
  2. Jim Nelson

    Jim Nelson Active Member

    Be sure to check your timing after the water pump job,mine was off.
     
  3. fmartin_gila

    fmartin_gila Active Member

    Very easy to get one tooth off when changing the timing belt. When a problem develops after some work, always recheck what you have done. From your description it kind of sounds like you may created a problem while doing the belt. Kind ofsounds like it will not run on the idle circuit which could be some crud in the carb bowl got into the low speed circuit by bumping the carb, another thing is the vacuum lines get brittle with age and it is very easy to crack one without realizing while doing some other work, this would throw the Air/Fuel mixture off enough to where it would not idle but would run at high speed even though very lean.

    You are right about the origins of your truck. I live in the Philippines and what I own was originally titled and registered in Japan as a 2002 Mazda Scrum. Was scrapped, sold & rebuilt in the Philippines and I now have it registered as a 2014 Suzuki CarryVan. You can go to suzuki.epcdata.ru/carry/ to find a very good parts lookup.

    Fred
     
    Last edited: Oct 27, 2015
  4. garrett

    garrett New Member

    i have triple checked my timing because initially thats what i thouht it was myself even thouh i marked everything when i changed out the water pump may have been a tooth off or so. i have ordered a new carb rebuild kit and i was thinkin of replacing all the vavcuum lines as well. guess i will see where that gets me. thanks for the advice gents.
     

Share This Page