1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Engine will not run without choke (Subaru E10)

Discussion in 'Microvans' started by TheFarmer, May 1, 2011.

  1. TheFarmer

    TheFarmer New Member

    Hello,

    My name is Pim and I'm from The Netherlands. We bought an E12 minivan with an E10 engine, but we can't get it running smooth. This is the problem:

    The engine can start with the choke on, but when we switch the choke off after a while, the engine stops running. With the carb on choke, the engine runs fine.

    This is what we did already:

    - cleaned the carb
    - cleaned air filter
    - cleaned fuel tank, lines, pump etc.
    - there is fuel in the float bowl al the time
    - cleaned, adjusted and checked ignition
    - looked for air leaks (false air)

    On the carb we found an electrical choke or something like that. (see attachment, red arrow). We think that is our problem. On this solenoid there is 12V al the time. When we remove the pin inside the solenoid, the engine can idle without the choke but do not respond on the throttle. With the choke on, everything works fine again.

    What is this solenoid and why is there 12V al the time?

    I hope someone can help us out here.

    [​IMG]
     
  2. greg0187

    greg0187 Moderator Staff Member

    Sounds like its starving for fuel. I would check and recheck the carb and make sure all the jets are clean. don't know about that solenoid. good luck!
     
  3. fupabox

    fupabox Active Member

    the solenoid is the fuel cut off solenoid...it allows fuel to flow to the carb only when the ignition is on
     
  4. paulhills

    paulhills New Member

    hi did you manage to sort out your carb issue? i have a subaru sumo E10 with the same problem. any advise would be appreciated
    thanks
    Paul
     
  5. Krieger-san

    Krieger-san Member

    Mine does pretty much the same. Single barrel Hitachi, automatic choke.
    When cold, the engine will simply die off if I don't hold my foot on the gas. The engineer who took a look at it said that it's missing a spring somewhere close to the choke plate. Also, my vacuum lines are kind of messed up. I'm not sure, I will look into it.
     
  6. paulhills

    paulhills New Member

    hi, i managed to solve my carb issue (although im not exactly sure what solved it!). looking at your pic the insulation on the solenoid cable come away from the wire. mine was the same. so i cut it off and resoldered a good joint to the solenoid. also make sure you plug it into the wiring loom correctly. on mine the pin inside the white plug was offset, so you have to make sure you have it the right way round when you push it together to make sure it connects correctly. as mentioned above, the solenoid blocks the flow of fuel, until you turn the ignition on. then the current goes to the solenoid which magnetically draws the pin back, unblocking the flow. turn of the ignition and the spring pushes the pin back in place (blocking the flow). if that doesnt work i would recommend cleaning the carb again. i did a thorough job the first time, but sprayed it through with carb cleaner again and an airline,. put it all back together and it worked first time. let us know how you get on
     
  7. subarukoekblik

    subarukoekblik New Member

    Hi, had the same problem with my E10. After I changed the sparkplugs it dissapeard but after a couple of weeks it came back. Now the engine is also shokking when my gas half way open, when he is totally open it stops again. You get used to it but im wander if it does damage in the longterm.
     
  8. KleinerMuck

    KleinerMuck New Member

    Hi Pim,
    if you give me your email, I can send you some more information.
    Regards
    KleinerMuck
     

Share This Page