1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[SOLVED] [Automatic Transmission Failsafe Mode Troubleshooting] Transmission Control Computer

Discussion in 'Daihatsu Hi jet' started by MrJPolito, Oct 14, 2021.

  1. DEG95DH

    DEG95DH Member

    @MrJPolito , sooo.........success?? I'm hoping to read soon that your AT now has 3 working gears! Fingers crossed!
     
  2. MrJPolito

    MrJPolito Active Member

    NOPE, not yet!

    So the wire is now continuous from the transmission wire harness to the computer under the dash, for both solenoids. Those pins I linked were the perfect fit for the wire harness. I did need to get some smaller gauge wire from Harbor Freight (22 AWG) to fit better, then I spliced it to the 18 AWG wire I already ran. Worked great. Continuity is perfect between the solenoid harness and the transmission computer. But I'm still getting a "Solenoid 1 not detected" error code. It must be the wiring behind the transmission oil pan, or the solenoid itself.

    I'm betting it's the wiring. The 22 gauge wire they used for these solenoids only has 6 strands of copper inside of it, and it breaks super easily.

    I did drive it in L and could tell it was shifting very subtly between 1 and 2, just like the Toyota transmission manual says it should with Solenoid 2 working but not 1, so that's promising. It's still stuck in 3 when I'm in D or 2 on the shifter, so Solenoid 1 is indeed doing nothing.

    It's been absolutely freezing outside and snowing so I haven't had the chance to get out there and drain the transmission yet. I guess I could also simply check the wire harness resistance. Either way, getting close here.
     
  3. MrJPolito

    MrJPolito Active Member

    Update: the wire harness going inside of the transmission is fine. The solenoid is stuck open again. This is a problem I had before when first tried cleaning out the solenoids: https://minitrucktalk.com/threads/pwr-button-on-dashboard.21518/#post-124305

    So, not only did I have a bad wire under the dash, I also have a stuck/clogged solenoid.

    I'm going to sonicate both of them in a water bath with some sonicating cleaner powder, dry them, and lubricate then as best I can before testing them with a battery again. Then hopefully the sticking stops.
     
  4. MrJPolito

    MrJPolito Active Member

    Come to think of it, it wasn't this bad before. Now there is zero continuity between the wire terminal and the solenoid housing, when before there was some but it had very high resistance. This solenoid could very well be fucked. I might have to try to find an equivalent at O'Reilly, which will be a nightmare.
     
  5. DEG95DH

    DEG95DH Member

    @MrJPolito , it physically pains me as I consider how many hours you have poured into your Hijet. I haven't figured out yet if you just got a total lemon, or if you are a glutton for punishment!?!? Stay the course. Thanks SO MUCH for all the posting and info sharing. I hope I never need half of it!
     
  6. Jigs-n-fixtures

    Jigs-n-fixtures Well-Known Member

    I’d check Toyota solenoids of the same era. I’m guessing the part is made by Aisan, or more probable Denso. Can you still read part numbers on it?

    RE: Ultrasound cleaning solution, I’d give the correct ATF a try before a water based solution. I clean guns in gun oil, and it gets the bolt crud off the direct impingement guns.
     
  7. MrJPolito

    MrJPolito Active Member

    I think I just got screwed over by the auction system. Turns out they probably don't even check for weird issues like the transmission being stuck in third gear when they give the cars a rating. If it drives forward and has no major oil leaks, they give it a 3.5 on the rating system. Ugh.

    Yes, it's AISIN but the part numbers written on them come up with nothing when you search for them. It says AISIN 5C24 on one and AISIN 5C29 on the other.

    I missed your post about using ATF. I sonicated them with trisodium phosphate and ultrasonic cleaning powder this afternoon. Bunch of gloopy oily blobs came out of both solenoids. Then I rinsed them with 95% ethanol and dried them for four hours at 50°C. The resistance is the same. Even the second solenoid that has continuity is getting ~950 ohms resistance when it's supposed to have about 20 ohms according to the Japanese manual. I sprayed them both with Seafoam Deep Creep and then dunked them into an aluminum can full of ATF. Will let them sit overnight and try jolting both with a car battery while they're submerged in the ATF to see if I can get them to click and maybe change the resistance.

    I have no idea if the resistance is supposed to be super high when they're stuck open, I'm just making assumptions based on what happened previously when I tested them with my battery -- when one of them got stuck and wouldn't click anymore, the resistance shot up to very high ohm values, and it eventually went back down and started clicking again when voltage was applied.
     
  8. MrJPolito

    MrJPolito Active Member

    IMG_20220209_005245_858.jpg IMG_20220209_005412_021.jpg

    Solenoid 2 (short bracket) - plugged it into the battery, it clicked once and shot ATF across the room, then stuck. Resistance was 900 ohms, now it's 10.5 MEGA ohms and it won't click again when voltage is applied.

    Solenoid 1 (long bracket) - still not responding to voltage. No measurable continuity or resistance.

    What even causes this to happen? Is the copper coil severed somehow? How would that even happen?

    I think I can find the short bracket solenoid at a parts store but the long one will be difficult and I haven't seen a Toyota equivalent from a similar year yet. They're also $100-250 per solenoid (which is insane), which is why I'm trying to get these ones to work again.
     
    Last edited: Feb 9, 2022
  9. MrJPolito

    MrJPolito Active Member

    IMG_20220209_152328_715.jpg IMG_20220209_152331_554.jpg received_286078340260419.jpeg

    So after soaking in ATF overnight, I took the whole can containing the ATF and my solenoids and put it into the sonicating water bath for like three hours. This heated up the transmission fluid and made a lot of bubbles rise to the surface, but otherwise I didn't notice any obvious changes (the fluid was opaque but returned to clear over time). My intention was to get the ATF to penetrate any spaces that I might not have been able to get at just by soaking alone.

    Then I plugged the solenoid into the car battery, while submerged, and wouldn't you know, it clicked. I can toggle it repeatedly and it doesn't stick. Resistance is measuring at 13 ohms, at the bottom of the range specified in the manual.

    Will reinstall later today and report back.
     
    DEG95DH likes this.
  10. DEG95DH

    DEG95DH Member

    Just to extrapolate some: an engine WITH oil might behave differently than an engine WITHOUT oil. That is my takeaway from all of this! ;)
     
    Last edited: Feb 14, 2022
  11. MrJPolito

    MrJPolito Active Member

    This is still not working consistently. Every time I check the resistance, without even applying power, it randomly measures as being in the mega-ohms resistance range. Haven't put it back into the car yet, but I'm sure as hell not going to do it if it's acting like this.

    I'm looking into alternative solenoids now. I ordered this part at O'Reilly -- https://www.oreillyauto.com/detail/c/power-torque/power-torque-solenoid/ptq7/te352/

    It's compatible with a wide range of Toyota models -- Camry / Corolla / Celica -- as well as Geo Metro, and a bunch of other random models from 1985-2007. Seems like the tech was fairly universal. Should arrive on Tuesday and I can go to the store to compare them to mine.

    If that doesn't work, I'll special-order this solenoid that fits a 1992 Daihatsu Charade (which is also 3-speed automatic) -- https://www.oreillyauto.com/detail/c/pioneer-inc/pioneer-inc-solenoid/pio0/772287/
     
  12. Jigs-n-fixtures

    Jigs-n-fixtures Well-Known Member

    Well pretty universal among the Toyota family. IIRC, the Geo Metros were what GM went to after they gave up on making Corollas every other week, and Corollas rebadged as Novas, on the opposite weeks, at the Long Beach Plant.
     
  13. MrJPolito

    MrJPolito Active Member

    I picked up Part # TE352 at O'Reilly and compared it to the solenoids I removed, but I decided to opt for something else. They're extremely expensive ($100 per solenoid new), and I would have to DIY the bracket (likely welding) so that it fits onto the existing solenoid bracket. I was planning to shove the new solenoid cylinder into the old bracket and stick it out the end, but the nozzle with the O-ring is extended further on the original Hijet solenoid, so this wasn't possible. Comparison photo below:

    Hijet-Solenoids_PXL_20220216_015724990.jpg

    So I told them I didn't think it would work and went on vacation to Florida for a week, and afterwards wound up at the junkyard in North Spokane (running on two hours of sleep and following 7 hours of flights). I went from 78 F weather in Florida to 19 F + wind chill in Washington, and I slogged around in the junkyard, opening dripping transmission pans until my hands were numb. Here's what I picked up:

    Hijet-Solenoids_PXL_20220223_174414037.jpg Hijet-Solenoids_PXL_20220223_174854934.jpg

    It was a little over $5.00 total for two sets of solenoids, one from a 1999 Geo / Chevy Metro, and the other from a 2001 Toyota Corolla LE. The nozzle tip that sticks into the transmission is the same diameter (9mm), but the brackets are obviously incompatible. Still beats spending $200 on two new solenoids that were also not compatible in the first place.

    I've tested the resistance and they're all fine, whereas my two solenoids are either way above what they should be or not even measurable.

    So now all I need to do is figure out how to attach this to the old bracket and I'm done. I will either use stainless steel cable ties, a hose clamp, tack welds, or some combination of the three. If anyone has a better idea, let me know. I don't really trust glue in the transmission lol.
     
  14. MrJPolito

    MrJPolito Active Member

    For future reference, Jeep Cherokee (up to 2001) seem to have a similar transmission solenoid to the one that I pulled out (almost looks exactly the same, with a different bracket shape):

    s-l1600.jpg

    Apparently these are compatible with the A340E transmission commonly found in many Toyotas / Jeep Cherokee / Lexus SC300, but the only ones I've seen with this exact shape (and extended nozzle) are in the Jeep Cherokee. If you can find one shaped like that, you could probably re-use your old bracket WITHOUT welding it. Just open up the old solenoid and take it out, and pop the new one in.
     
  15. MrJPolito

    MrJPolito Active Member

    Alright, fantastic news:

    I've installed the 2001 Toyota Corolla shift solenoids into my transmission (they popped right in) and I secured them to the old solenoid brackets with stainless steel cable ties and (in the case of solenoid 2) a metal wire. Photos:

    IMG_20220301_190612_369.jpg IMG_20220301_190609_985.jpg IMG_20220301_190607_178.jpg

    I accidentally cracked the wire harness brace that keeps the wire in position on solenoid 2 so I used a metal wire to twist it onto the bracket and make sure it doesn't fall off.

    Both of the solenoids feel tight and not like they'll fall out easily. I drove it around town and up hills and it's definitely shifting. It was rough at first but it smoothed out after driving for a while. Seems to work perfectly now.

    I also don't have a flashing PWR light as Ronso described, so I think that the Atrai S120V transmission computer is completely compatible with the S110P truck. The light should only flash if you have a transmission error code stored in your computer.


    So, to recap, if your automatic hijet is not shifting:

    1. Check for error codes on your transmission computer by jumping the diagnostic port pins described previously.

    2. If your PWR light doesn't flash at all when the pins are jumped, you should look into replacing your computer's capacitors.

    3. If you mess up your computer, try replacing it with one from another S100 series hijet (check Aleado Yahoo auctions, or Yokohama motors. This is rare and tends to be very expensive)

    4. If your transmission computer tells you that your solenoids aren't connected, check for wire continuity under the dash or check your solenoid resistance.

    5. If your solenoid resistance is above ~20 ohms, replace your solenoids with a $5 pair from a junkyard Toyota vehicle.

    Hope no one ever has to go through this, good luck lol.
     
    Last edited: Mar 1, 2022
    Jason Misora, DEG95DH and shogun like this.
  16. shogun

    shogun Active Member

    Congrats. Thanks for the detailed info and your research on this, that will definitely help others in the future. Glad I could help a bit to find a solution.
     
    Last edited: Apr 15, 2022
  17. DEG95DH

    DEG95DH Member

    @MrJPolito , that IS fantastic news!! I'm glad all your diligence panned out to success.

    I'm still really pleased with my automatic. It's nice just jumping in and driving. I think clutching/shifting in the small cab would annoy me after awhile.
     
  18. Yesterday I got my transmission computer back from getting new caps and I can be added to the list of successful rebuilds. Drives very nicely shifts smoothly at 20 and 50 kph so absolutely no complaints. However I do not have a pwr light and nothing seems to change when switching the pwr switch on or off. Really appreciate @MrJPolito for the forums and all the others who provided information and guidance to find this solution.
     
    Jason Misora likes this.
  19. Btimothy4

    Btimothy4 New Member

    Just purchased a 1996 Atrai, automatic and am having the same issue- no PWR light and doesn't seem to be shifting in all 3 gears. Manual shifting works fine in L to 2, but not in Drive. Thinking its the Trans Controller - is there a shop that anyone has been using to replacing the computer's capacitors? Or? I have asked a few TV shops and they wont touch it
     
  20. MrJPolito

    MrJPolito Active Member

    Have you looked at the computer yet? If it's in a metal box and not a plastic one, it'll be an easier one to fix. I'm pretty sure the metal box ones have removeable covers and they shouldn't have the weird plastic potting stuff covering the board that makes it impossible to solder the capacitors. It's way easier to work on than the plastic one that I had.
     
  21. Btimothy4

    Btimothy4 New Member

    Thanks for getting back so quickly - I haven't yet, my plan is to tear into it tomorrow. I will update then
    Again, thanks!
     
  22. Btimothy4

    Btimothy4 New Member

    I do have a metal box and yes it opened right up - can anyone tell from this photo which ones are the ones to change out?

    Trans comp.jpg
     
  23. DEG95DH

    DEG95DH Member

    @Btimothy4 , No, I have no clue. But I speculate you should start with your 6 capacitors. That has been the problem on the other ones. Yours looks SOOOOOO much easier to do....I'm jealous.

    upload_2022-10-12_7-35-30.png
     
  24. Btimothy4

    Btimothy4 New Member

    Thanks!
    I was thinking its way easier to replace all of them, rather then guess
    I have a good friend who builds out circuit boards replacing them and giving it all a once over. Will update the thread when completed
     
  25. Jigs-n-fixtures

    Jigs-n-fixtures Well-Known Member

    I’m seeing 24 or 25 capacitors, but the C1 to C6 are the most probable to have failed.
     
  26. Btimothy4

    Btimothy4 New Member

    Installed the rebuilt TCM and now the PWR light comes on! I went for a drive and shifters from 1 to 2, then seem to drop into Neutral and could get it into 3rd. I am assuming its low on fluid and am going to replace the fluid first. Does anyone know the correct fluid and capacity?
     
  27. MrJPolito

    MrJPolito Active Member

    The PWR light will turn on if there is an error message logged in the computer. Somewhere in this thread I described how to use a paperclip to jump terminals on a diagnostic port to retrieve error codes. Check that.

    Edit: here is the link to that post
    https://minitrucktalk.com/threads/a...ion-control-computer.21545/page-2#post-124966
     
  28. Btimothy4

    Btimothy4 New Member

    Thanks, I will re-read and give that a try as well - appreciate the support!
     
  29. Btimothy4

    Btimothy4 New Member

    Well, it turned out the board that I had updated was bad. I actually found 2 of them on Yahoo and one of them showed up today - it was like brand new inside and plugged it in and now it's all fixed!
    Can't thank Mr JP for all the hard work and help in figuring this all out - beyond happy!
     
    MrJPolito likes this.

Share This Page