1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

'91 Mitsi Minicab wont start after warmed up

Discussion in 'Mitsubishi Minicab' started by TooManyProjects, Aug 1, 2020.

  1. Hello Ladies and Germs!! Im having issues with my 1991 Mitsubishi Minicab not starting after the engine is warmed up. I checked for spark...good. I checked fuel delivery...good. It will start when the engine is cold, but reluctantly. Once started, it will run, but the response from the throttle is weak. Almost to the point of killing the engine. It just recently started doing this, after it sat for 2 months. It likes to backfire from the exhaust when i try to start it cold. Sounds like a single gun shot. And LOUD.

    Symptoms:
    barely starts when engine is cold

    wont restart after engine is warmed up

    backfires from exhaust and carb when trying to start when warmed up or cold

    when started, throttle response is such that it "bogs down" the engine when "snapping" the throttle, when it does start

    PLEASE HELP! As i am at my wits end with the little monster.
    thanks much,
    Joe
     
  2. Heiny

    Heiny Member

    Can you check timing?
     
    TooManyProjects likes this.
  3. Not sure how to check timing on these things. As there is no harmonic balancer. No plug in the timing belt cover to see timing marks. No way, that i can see, to use a timing light.
    I have to buy a tachometer to see what the idle speed is.
     
  4. I did, however, give the distributor a turn, and it will reluctantly start now when its warmed up. Its almost as if there needs to be more adjustment on the distributor. Because its all the way one way, and could use a bit more of a turn i think.
     
  5. Is it possible that the timing belt jumped a single tooth?
    That might account for the improvement when turning the distributor.
     
  6. Jigs-n-fixtures

    Jigs-n-fixtures Well-Known Member

    Timing is Probably on the flywheel.
     
    TooManyProjects likes this.
  7. Wow. Thats a new one on me. Ok. Ill look into it. Thanks!
     
  8. Limestone

    Limestone Active Member

    Those Mate marks have to line up, otherwise your spinning your wheels, chasing your tail, you get the point!!!
     
  9. I was able to find a thread on here about timing marks on the flywheel and timing belt gears. I going to devote a night after work to looking over all that and deciphering the thread i found. The thread didnt mention (that i could see) what type of mini rig they were fooling with, but it gives me a direction to go. And areas to look in and what to look for. Trust me, ill be on here in a flash as soon as i run into a snag. Haha!!! Thanks much!
     
  10. Given the trouble shooting i have done so far, and what minor adjustments i made, is it possible that the timing belt jumped a single tooth? Hence the adjustment of the distributor and the improvement it made.
     
  11. Heiny

    Heiny Member

    Yes maybe, that is why I asked. How many miles are on it? These belts don’t seem to last very long. But these carbs are crap and the alcohol in the gas doesn’t help them any either.
     
  12. Limestone

    Limestone Active Member

    Every engine, has timing mate marks that have to line up, if not the internal parts would damage each other! If the marks are off a little, like one tooth, then chances are the parts won't collide and damage each other, but you will have a heck of a time getting your unit to start, run, etc......So it won't hurt to take some of the guess work out, and verify the timing mate marks on the end of the cam shaft and the belt pulley(the pulley with the teeth on it)! The easy way, if you've never done so before, is to locate the mark on the belt pulley first, then, as it rotates around, pointing the mark, in most cases up, you can find the other mark! Depending how dirty it is, you might need to clean up where the marks are with a small wire brush! In another post on the Forum, someone else found their marks highlighted with a paint stick marker, sometimes guy's will do this to highlight the marks! Just verify the marks, under the paint, or marking's of some kind, in case a mistake was made previously, and the indents, or steel stamped mark's are misidentified! Crazier things have happened. While your there diagnose the belts age and note, if it needs replacement! Try not to twist and bend the belt, causing cracks and possible further damage to the belt! Check the tension on the belt if it's good, it might need an adjustment on the eccentric belt Tensioner! Good Luck!
    Limestone
     
  13. Jigs-n-fixtures

    Jigs-n-fixtures Well-Known Member

    The ignition timing marks are frequently on the flywheel, because it is closer to the distributor, and more easily accessed through the maintenance hatch while adjusting the distributor.
     
    TooManyProjects likes this.
  14. Limestone

    Limestone Active Member

    Absolutely correct, Jigs, as you know, the ignition timing marks are in the flywheel under that small little rubber window that opens, on the Mini's, close to the distributor. Like we've discussed before, if the mate marks, behind the timing belt cover aren't lined up properly first, your unit will never run right!
     
    TooManyProjects likes this.
  15. Jigs-n-fixtures

    Jigs-n-fixtures Well-Known Member

    You can check the cam timing by pulling the valve cover, and checking whether the valves that should be loose at TDC, are actually loose.
     
    TooManyProjects likes this.
  16. About 42,000 miles, or 67,000 km.
    I got in the woods and broke the speedo cable last year. Its got a Mukuni carb on it. It seems to be working properly, but im positive it could use a good going over and a kit. I think first order of business might be going over yhe millions of vacuum lines and making sure thethey all seal properly and replace one that arent tight.
     
  17. If i end up replacing the timing belt, which is likely, it will definitely get a valve adjustment.
    It the little demons defense, i had been driving it alot more than usual, and longer distances. Up until i parked it the last time, it ran pretty good. However, it did have a tendency to blow a little black smoke (raw fuel) at start up and slightly after it warmed up and was being driven. Stand3near the exhaust end, you could smell it was running abit rich.
     
  18. As far as the "mate marks" go, would it be wise to remove the timing cover and make sure those and the flywheel marks are in order at the same time? Or does it matter? Assuming if one is correct, so shall be the other.
     
  19. Limestone

    Limestone Active Member

    Well, in regard to the belt possibly jumping a tooth, and the unknown age of the timing belt, you can kill two birds with one stone, by removing the cover, you can inspect both! If your having that much trouble setting your timing, why not be sure?
     
    TooManyProjects likes this.
  20. That was my thought on the whole thing. In all likelihood, i will just replace the timing belt. But I would like to "trouble shoot" before i do. I havent been into the engine yet, and know very little about it. It will be a good learning experience i think. I know about "regular" engines, but since parts are sometimes difficult to come by, i have been hesitant to just jump in head first and start ripping and tearing, like i would on say a 350 small block Chevy.
    All the insight from everyone on here is always helpful and always very much appreciated. I hope that after this little episode of "Joe's Funny Little Truck" as everyone refers to it, is over, i too will be able to contribute to the forum in some way.
     

Share This Page